Back to overview
Degraded

Elevated API latency

May 26 at 05:23pm PDT
Affected services
Call Creation

Resolved
May 26 at 05:49pm PDT

We have identified the root cause and latency has returned to normal.

Created
May 26 at 05:23pm PDT

Dashboard and call creation are seeing very high API latency. We're investigating.