Back to overview
Downtime
Call Creation Failures
Jun 12, 2025 at 6:00pm UTC
Affected services
Call Creation
Resolved
Jun 12, 2025 at 8:43pm UTC
Call creation has recovered.
Apologies for the disruption and thank you for your patience.
Affected services
Updated
Jun 12, 2025 at 8:12pm UTC
We are still impacted by the worldwide GCP outage but starting to see signs of recovery.
Affected services
Updated
Jun 12, 2025 at 6:06pm UTC
A critical dependency is unavailable and we are working to mitigate.
Affected services
Created
Jun 12, 2025 at 6:00pm UTC
Call creation failures are elevated, we are actively investigating.
Affected services